Excel for Windows support

Supported Excel for Windows Versions

  • Excel 2007
  • Excel 2010
  • Excel 2013
  • Office 365 Desktop

Supported Windows Versions

  • Windows 7
  • Windows 8
  • Windows 8.1

Additionally, Microsoft .NET Framework 4.0 is required. This will be installed for you automatically during the add-in setup process if you do not have it installed.

Excel 2007 has noticeably worse performance than Excel 2010 or 2013; we recommend Excel 2010 or Excel 2013 for the best possible experience.

Windows XP is not supported.

Still need help? Contact Us Contact Us